Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(56)

Unified Diff: webrtc/modules/congestion_controller/delay_based_bwe.h

Issue 2710093004: Rename webrtc::PacketInfo to webrtc::PacketFeedback (Closed)
Patch Set: Rebased Created 3 years, 9 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
Index: webrtc/modules/congestion_controller/delay_based_bwe.h
diff --git a/webrtc/modules/congestion_controller/delay_based_bwe.h b/webrtc/modules/congestion_controller/delay_based_bwe.h
index c02182bdd312e2c8ea835f0f8aeafe482fb3a532..c5f0f6182805bfa80c3e0dec2ee3d0b86b1c3a65 100644
--- a/webrtc/modules/congestion_controller/delay_based_bwe.h
+++ b/webrtc/modules/congestion_controller/delay_based_bwe.h
@@ -50,7 +50,7 @@ class DelayBasedBwe {
virtual ~DelayBasedBwe() {}
Result IncomingPacketFeedbackVector(
- const std::vector<PacketInfo>& packet_feedback_vector);
+ const std::vector<PacketFeedback>& packet_feedback_vector);
void OnRttUpdate(int64_t avg_rtt_ms, int64_t max_rtt_ms);
bool LatestEstimate(std::vector<uint32_t>* ssrcs,
uint32_t* bitrate_bps) const;
@@ -81,7 +81,7 @@ class DelayBasedBwe {
const bool in_experiment_;
};
- Result IncomingPacketInfo(const PacketInfo& info);
+ Result IncomingPacketFeedback(const PacketFeedback& packet_feedback);
Result OnLongFeedbackDelay(int64_t arrival_time_ms);
// Updates the current remote rate estimate and returns true if a valid
// estimate exists.

Powered by Google App Engine
This is Rietveld 408576698