Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(323)

Unified Diff: webrtc/modules/rtp_rtcp/include/rtp_rtcp.h

Issue 2495553002: Add overhead per packet observer to the rtp_sender. (Closed)
Patch Set: Rename RtpOverheadSizeChanged to UpdateRtpOverheadSize. Created 4 years, 1 month ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
Index: webrtc/modules/rtp_rtcp/include/rtp_rtcp.h
diff --git a/webrtc/modules/rtp_rtcp/include/rtp_rtcp.h b/webrtc/modules/rtp_rtcp/include/rtp_rtcp.h
index 1e4da64220d1d91577a38ed3e1277a349bcdff59..fdcdeef041b9f9fabe4559a36c93232560c4780d 100644
--- a/webrtc/modules/rtp_rtcp/include/rtp_rtcp.h
+++ b/webrtc/modules/rtp_rtcp/include/rtp_rtcp.h
@@ -25,6 +25,7 @@
namespace webrtc {
// Forward declarations.
+class OverheadSizeObserver;
class RateLimiter;
class ReceiveStatistics;
class RemoteBitrateEstimator;
@@ -83,6 +84,7 @@ class RtpRtcp : public Module {
RtcEventLog* event_log = nullptr;
SendPacketObserver* send_packet_observer = nullptr;
RateLimiter* retransmission_rate_limiter = nullptr;
+ OverheadSizeObserver* overhead_size_observer = nullptr;
private:
RTC_DISALLOW_COPY_AND_ASSIGN(Configuration);

Powered by Google App Engine
This is Rietveld 408576698