Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(400)

Unified Diff: webrtc/common_types.h

Issue 2495553002: Add overhead per packet observer to the rtp_sender. (Closed)
Patch Set: Rename RtpOverheadSizeChanged to UpdateRtpOverheadSize. Created 4 years, 1 month ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
Index: webrtc/common_types.h
diff --git a/webrtc/common_types.h b/webrtc/common_types.h
index 24ba00a8450e4e9869c544f772c774105af0100c..89361d499874c6b36fc6a1ca863fd80ee42edf48 100644
--- a/webrtc/common_types.h
+++ b/webrtc/common_types.h
@@ -298,6 +298,14 @@ class SendPacketObserver {
uint32_t ssrc) = 0;
};
+// Callback, used to notify an observer when the overhead per packet
+// has changed.
+class OverheadSizeObserver {
+ public:
+ virtual ~OverheadSizeObserver() = default;
+ virtual void OnOverheadSizeChanged(int overhead_bytes_per_packet) = 0;
danilchap 2016/11/16 08:55:05 size_t look like preferred type for a variable rep
michaelt 2016/11/16 09:27:09 Acknowledged.
+};
+
// ==================================================================
// Voice specific types
// ==================================================================
« no previous file with comments | « no previous file | webrtc/modules/rtp_rtcp/include/rtp_rtcp.h » ('j') | webrtc/modules/rtp_rtcp/source/rtp_sender.cc » ('J')

Powered by Google App Engine
This is Rietveld 408576698