Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(1798)

Unified Diff: webrtc/modules/rtp_rtcp/source/rtp_sender.h

Issue 2448463003: Rename {,Set}GenericFECStatus to {,Set}UlpfecConfig. (Closed)
Patch Set: Created 4 years, 2 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
Index: webrtc/modules/rtp_rtcp/source/rtp_sender.h
diff --git a/webrtc/modules/rtp_rtcp/source/rtp_sender.h b/webrtc/modules/rtp_rtcp/source/rtp_sender.h
index 6b5a6c740a94d7c73d7e60358b972941fe593f32..d7c8ae32aaace3b10c76555f0c2758a1cb670169 100644
--- a/webrtc/modules/rtp_rtcp/source/rtp_sender.h
+++ b/webrtc/modules/rtp_rtcp/source/rtp_sender.h
@@ -184,13 +184,13 @@ class RTPSender {
uint32_t MaxConfiguredBitrateVideo() const;
// FEC.
- void SetGenericFECStatus(bool enable,
- uint8_t payload_type_red,
- uint8_t payload_type_fec);
+ void SetUlpfecConfig(bool ulpfec_enabled,
+ int red_payload_type,
+ int ulpfec_payload_type);
- void GenericFECStatus(bool* enable,
- uint8_t* payload_type_red,
- uint8_t* payload_type_fec) const;
+ void UlpfecConfig(bool* ulpfec_enabled,
+ int* red_payload_type,
+ int* ulpfec_payload_type) const;
int32_t SetFecParameters(const FecProtectionParams *delta_params,
const FecProtectionParams *key_params);

Powered by Google App Engine
This is Rietveld 408576698