Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(69)

Issue 2318953005: New helper class AdaptedVideoSource. (Closed)

Created:
4 years, 3 months ago by nisse-webrtc
Modified:
4 years, 3 months ago
CC:
webrtc-reviews_webrtc.org, tterriberry_mozilla.com, the sun
Target Ref:
refs/pending/heads/master
Project:
webrtc
Visibility:
Public.

Description

New helper class AdaptedVideoSource. Keeps a TimestampAligner, a VideoAdapter and VideoBroadcaster. Intended to be used by all capturer-like VideoTrackSource:s, to avoid duplication of common adaptation logic. Superseded by https://codereview.webrtc.org/2328333002/ BUG=

Patch Set 1 #

Unified diffs Side-by-side diffs Delta from patch set Stats (+179 lines, -159 lines) Patch
M webrtc/api/androidvideotracksource.h View 3 chunks +2 lines, -17 lines 0 comments Download
M webrtc/api/androidvideotracksource.cc View 3 chunks +10 lines, -42 lines 0 comments Download
M webrtc/media/BUILD.gn View 1 chunk +2 lines, -0 lines 0 comments Download
A webrtc/media/base/adaptedvideosource.h View 1 chunk +69 lines, -0 lines 0 comments Download
A webrtc/media/base/adaptedvideosource.cc View 1 chunk +70 lines, -0 lines 0 comments Download
M webrtc/media/base/videocapturer.h View 5 chunks +5 lines, -39 lines 0 comments Download
M webrtc/media/base/videocapturer.cc View 6 chunks +19 lines, -61 lines 0 comments Download
M webrtc/media/media.gyp View 1 chunk +2 lines, -0 lines 0 comments Download

Messages

Total messages: 6 (2 generated)
nisse-webrtc
This is a request-for-comments cl. Background is that we'd like to eliminate the use of ...
4 years, 3 months ago (2016-09-08 12:41:19 UTC) #2
magjed_webrtc
On 2016/09/08 12:41:19, nisse-webrtc wrote: > This is a request-for-comments cl. > > Background is ...
4 years, 3 months ago (2016-09-08 14:42:01 UTC) #3
nisse-webrtc
On 2016/09/08 14:42:01, magjed_webrtc wrote: > 2. What is VideoTrackSource used for? If it's only ...
4 years, 3 months ago (2016-09-09 08:59:09 UTC) #4
perkj_webrtc
4 years, 3 months ago (2016-09-10 07:06:16 UTC) #5
On 2016/09/09 08:59:09, nisse-webrtc wrote:
> On 2016/09/08 14:42:01, magjed_webrtc wrote:
> > 2. What is VideoTrackSource used for? If it's only one subclass, can you
merge
> > it with that one? I don't think that class deserves such a generic name.
> 
> It's used directly by RTPReceiver, and inherited by VideoCapturerTrackSource.
I
> guess we don't want adaptation logic for remote sources?
>   
> > 3. We don't have an enable_video_adapter flag in Android (and we don't want
> > one). Can't we just leave enable_video_adapter in cricket::VideoCapturer and
> not
> > add it to the new class?
> 
can't we just skip enable_video_adapter()? Is it used by any production code or
just tests? 

> That would be good. I'm also considering untangling the timestamping logic and
> adaptation. In a different cl, Per suggested that TimestampAligner should have
a
> single public method, TranslateTimestamp, and in that case doesn't have to be
> part of AdaptFrame.
> 
> > Also, can you move GetStats 
> 
> Maybe. In that case, it would become more natural to have it inherit
> VideoTrackSourceInterface, and have the VideoBroadcaster as a member (in the
> current patch set I inherit VideoBroadcaster, because I find it a bit awkward
> with a looong chain of delegations of AddOrUpdateSink.
> 
> > and OnSinkWantsChanged into
> > the new class? 
> 
> Then the apply_rotation_ flag would move into the new class as well? Makes
some
> sense.

So this turns into a base class for  implementing VideoTrackSourceInterface that
Chrome and Android/ ios can use instead of as now is, cricket::VideoCapturer?
sgmt. 
Be carefull with bool IsScreenCast and bool NeedsDenoising()

Powered by Google App Engine
This is Rietveld 408576698