Index: webrtc/media/base/videosinkinterface.h |
diff --git a/webrtc/media/base/videosinkinterface.h b/webrtc/media/base/videosinkinterface.h |
index 9b8ba318623e6b43b2db726f7f84f099f956de34..4d8614d0748b202746fada91c3d8bc0183a8db25 100644 |
--- a/webrtc/media/base/videosinkinterface.h |
+++ b/webrtc/media/base/videosinkinterface.h |
@@ -13,10 +13,15 @@ |
namespace rtc { |
+struct VideoSinkCapabilities { |
+ bool can_apply_rotation_ = false; |
pthatcher
2016/02/01 18:40:54
Shouldn't that be can_apply_rotation (no "_" on th
perkj_webrtc
2016/02/02 16:24:00
Done.
|
+}; |
+ |
template <typename VideoFrameT> |
class VideoSinkInterface { |
public: |
virtual void OnFrame(const VideoFrameT& frame) = 0; |
+ virtual VideoSinkCapabilities getCapabilities() { return VideoSinkCapabilities(); } |
pthatcher
2016/02/01 18:40:54
These needs a SignalCapabilitiesChanged signal to
pthatcher
2016/02/01 18:40:54
Can you rename getCapabilities() to be just capabi
nisse-webrtc
2016/02/02 09:52:30
Will all flags really be capabilities, or is it be
nisse-webrtc
2016/02/02 09:52:30
I'm not sure what you mean by "signal" here. We re
perkj_webrtc
2016/02/02 16:24:00
I had not got that far yesterday but I would reall
|
protected: |
~VideoSinkInterface() {} |