Index: webrtc/modules/rtp_rtcp/include/flexfec_receiver.h |
diff --git a/webrtc/modules/rtp_rtcp/include/flexfec_receiver.h b/webrtc/modules/rtp_rtcp/include/flexfec_receiver.h |
index ae4696441bb236853412504d429d761decb050c4..5d5ef924fa50a2d6b949ca13ac1080219c0b9211 100644 |
--- a/webrtc/modules/rtp_rtcp/include/flexfec_receiver.h |
+++ b/webrtc/modules/rtp_rtcp/include/flexfec_receiver.h |
@@ -39,8 +39,10 @@ class FlexfecReceiver { |
// Protected to aid testing. |
protected: |
- bool AddReceivedPacket(const RtpPacketReceived& packet); |
- bool ProcessReceivedPackets(); |
+ std::unique_ptr<ForwardErrorCorrection::ReceivedPacket> AddReceivedPacket( |
brandtr
2017/09/14 11:49:45
Maybe rename, since it only converts the packet no
nisse-webrtc
2017/09/14 12:55:51
Any naming suggestion? It seems the only member va
brandtr
2017/09/14 13:14:15
Maybe 'ConvertPacket', but then it would make sens
|
+ const RtpPacketReceived& packet); |
+ bool ProcessReceivedPacket( |
+ const ForwardErrorCorrection::ReceivedPacket& received_packet); |
private: |
// Config. |
@@ -50,8 +52,6 @@ class FlexfecReceiver { |
// Erasure code interfacing and callback. |
std::unique_ptr<ForwardErrorCorrection> erasure_code_ |
RTC_GUARDED_BY(sequence_checker_); |
- ForwardErrorCorrection::ReceivedPacketList received_packets_ |
- RTC_GUARDED_BY(sequence_checker_); |
ForwardErrorCorrection::RecoveredPacketList recovered_packets_ |
RTC_GUARDED_BY(sequence_checker_); |
RecoveredPacketReceiver* const recovered_packet_receiver_; |