Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(1197)

Unified Diff: webrtc/rtc_base/criticalsection_unittest.cc

Issue 3008193002: Revert of Rename thread annotation macros to have RTC prefix for syncrhonization primitives. (Closed)
Patch Set: Created 3 years, 3 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
« no previous file with comments | « webrtc/rtc_base/criticalsection.cc ('k') | webrtc/rtc_base/messagequeue.cc » ('j') | no next file with comments »
Expand Comments ('e') | Collapse Comments ('c') | Show Comments Hide Comments ('s')
Index: webrtc/rtc_base/criticalsection_unittest.cc
diff --git a/webrtc/rtc_base/criticalsection_unittest.cc b/webrtc/rtc_base/criticalsection_unittest.cc
index c264e44bd7d3b2c0a05e4dd524c9e782e6188c0b..2e136bf80418a3837837caf0bd9ee0fb6bd7eaf9 100644
--- a/webrtc/rtc_base/criticalsection_unittest.cc
+++ b/webrtc/rtc_base/criticalsection_unittest.cc
@@ -113,10 +113,14 @@
int shared_value_;
};
-class RTC_LOCKABLE CriticalSectionLock {
- public:
- void Lock() RTC_EXCLUSIVE_LOCK_FUNCTION() { cs_.Enter(); }
- void Unlock() RTC_UNLOCK_FUNCTION() { cs_.Leave(); }
+class LOCKABLE CriticalSectionLock {
+ public:
+ void Lock() EXCLUSIVE_LOCK_FUNCTION() {
+ cs_.Enter();
+ }
+ void Unlock() UNLOCK_FUNCTION() {
+ cs_.Leave();
+ }
private:
CriticalSection cs_;
« no previous file with comments | « webrtc/rtc_base/criticalsection.cc ('k') | webrtc/rtc_base/messagequeue.cc » ('j') | no next file with comments »

Powered by Google App Engine
This is Rietveld 408576698