Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(8)

Unified Diff: webrtc/call/secondary_rtp_sinks_container.h

Issue 2974453002: Protected streams report RTP messages directly to the FlexFec streams (Closed)
Patch Set: . Created 3 years, 5 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
Index: webrtc/call/secondary_rtp_sinks_container.h
diff --git a/webrtc/call/secondary_rtp_sinks_container.h b/webrtc/call/secondary_rtp_sinks_container.h
new file mode 100644
index 0000000000000000000000000000000000000000..b0f02657be8d5302bc41c21818c4ef0f7b60fa5e
--- /dev/null
+++ b/webrtc/call/secondary_rtp_sinks_container.h
@@ -0,0 +1,34 @@
+/*
+ * Copyright (c) 2017 The WebRTC project authors. All Rights Reserved.
+ *
+ * Use of this source code is governed by a BSD-style license
+ * that can be found in the LICENSE file in the root of the source
+ * tree. An additional intellectual property rights grant can be found
+ * in the file PATENTS. All contributing project authors may
+ * be found in the AUTHORS file in the root of the source tree.
+ */
+#ifndef WEBRTC_CALL_SECONDARY_RTP_SINKS_CONTAINER_H_
+#define WEBRTC_CALL_SECONDARY_RTP_SINKS_CONTAINER_H_
+
+namespace webrtc {
+
+class RtpPacketSinkInterface;
+
+// TODO(eladalon): !!! Find a better name?
+
+// By inheriting this class, a subclass of RtpPacketSinkInterface may provide
+// secondary sinks the ability to register with it, receiving OnRtpPacket()
+// called for them too over packets which get routed to the primary sink.
+// One usage for this is FlexFEC, which needs to see the packets of the
+// streams which it protects.
+class SecondaryRtpSinksContainer {
danilchap 2017/07/19 12:07:25 I can see several implementation of this interface
eladalon 2017/07/21 14:42:08 This TODO is about this: // TODO(eladalon): !!!
+ public:
+ virtual ~SecondaryRtpSinksContainer() = default;
+
+ virtual void AddSecondarySink(RtpPacketSinkInterface* sink) = 0;
+ virtual void RemoveSecondarySink(const RtpPacketSinkInterface* sink) = 0;
+};
+
+} // namespace webrtc
+
+#endif // WEBRTC_CALL_SECONDARY_RTP_SINKS_CONTAINER_H_

Powered by Google App Engine
This is Rietveld 408576698