Index: webrtc/video_receive_stream.h |
diff --git a/webrtc/video_receive_stream.h b/webrtc/video_receive_stream.h |
index b3a98c617ac2ebc120bf50f557faf537af47ba52..744797defaa91ea29fafbe753ee2697ece645777 100644 |
--- a/webrtc/video_receive_stream.h |
+++ b/webrtc/video_receive_stream.h |
@@ -18,6 +18,9 @@ |
#include "webrtc/api/call/transport.h" |
#include "webrtc/base/platform_file.h" |
+// TODO(eladalon): !!! Good? Bad? Do we want to have these functions explicitly |
+// part of the interface, without inheriting them, perhaps? |
+#include "webrtc/call/secondary_rtp_sinks_container.h" |
#include "webrtc/common_types.h" |
#include "webrtc/common_video/include/frame_callback.h" |
#include "webrtc/config.h" |
@@ -27,7 +30,7 @@ namespace webrtc { |
class VideoDecoder; |
-class VideoReceiveStream { |
+class VideoReceiveStream : public SecondaryRtpSinksContainer { |
public: |
// TODO(mflodman) Move all these settings to VideoDecoder and move the |
// declaration to common_types.h. |