Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(1706)

Unified Diff: webrtc/call/rtp_transport_controller_receive_interface.h

Issue 2886993005: Introduce RtpStreamReceiver and RtpStreamReceiverControllerInterface. (Closed)
Patch Set: Created 3 years, 7 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
Index: webrtc/call/rtp_transport_controller_receive_interface.h
diff --git a/webrtc/call/rtp_transport_controller_receive_interface.h b/webrtc/call/rtp_transport_controller_receive_interface.h
new file mode 100644
index 0000000000000000000000000000000000000000..c5821ca011febf58480cf59decf201158d85557c
--- /dev/null
+++ b/webrtc/call/rtp_transport_controller_receive_interface.h
@@ -0,0 +1,35 @@
+/*
+ * Copyright (c) 2017 The WebRTC project authors. All Rights Reserved.
+ *
+ * Use of this source code is governed by a BSD-style license
+ * that can be found in the LICENSE file in the root of the source
+ * tree. An additional intellectual property rights grant can be found
+ * in the file PATENTS. All contributing project authors may
+ * be found in the AUTHORS file in the root of the source tree.
+ */
+#ifndef WEBRTC_CALL_RTP_TRANSPORT_CONTROLLER_RECEIVE_INTERFACE_H_
+#define WEBRTC_CALL_RTP_TRANSPORT_CONTROLLER_RECEIVE_INTERFACE_H_
+
+#include <memory>
+
+#include "webrtc/call/rtp_demuxer.h"
+
+namespace webrtc {
+
+class RtpTransportReceiver {
pthatcher1 2017/05/17 23:24:53 What is this? No comment. No methods. And I'm g
+ public:
+ virtual ~RtpTransportReceiver() {}
+};
+
+// This class acts as a factory for RtpTransportReceive objects.
+class RtpTransportControllerReceiveInterface {
pthatcher1 2017/05/17 23:24:53 I still don't like this name. RtpReceiverControll
nisse-webrtc 2017/05/18 08:45:43 I'm open to renaming (as long as RtpTransportContr
pthatcher1 2017/05/24 03:57:38 A controller is a thing that creates, owns, and de
+ public:
+ virtual ~RtpTransportControllerReceiveInterface() {}
+ virtual std::unique_ptr<RtpTransportReceiver> CreateReceiver(
pthatcher1 2017/05/17 23:24:53 This could use a method also. You put in a sink a
nisse-webrtc 2017/05/18 08:45:43 On an abstract level, a receiver is a handle to th
+ uint32_t ssrc,
+ RtpPacketSinkInterface* sink) = 0;
+};
danilchap 2017/05/19 15:37:43 OnRtpPacket or similar likely should be part of th
nisse-webrtc 2017/05/22 07:09:37 If we add that interface, I think it should take a
+
+} // namespace webrtc
+
+#endif // WEBRTC_CALL_RTP_TRANSPORT_CONTROLLER_RECEIVE_INTERFACE_H_

Powered by Google App Engine
This is Rietveld 408576698