Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(87)

Side by Side Diff: webrtc/call/rtp_transport_controller.h

Issue 2685673003: Define RtpTransportControllerSendInterface. (Closed)
Patch Set: Comment improvements. Created 3 years, 9 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View unified diff | Download patch
OLDNEW
(Empty)
1 /*
2 * Copyright (c) 2017 The WebRTC project authors. All Rights Reserved.
3 *
4 * Use of this source code is governed by a BSD-style license
5 * that can be found in the LICENSE file in the root of the source
6 * tree. An additional intellectual property rights grant can be found
7 * in the file PATENTS. All contributing project authors may
8 * be found in the AUTHORS file in the root of the source tree.
9 */
10
11 #ifndef WEBRTC_CALL_RTP_TRANSPORT_CONTROLLER_H_
danilchap 2017/03/16 11:38:58 may be rename this file to rtp_transport_controlle
nisse-webrtc 2017/03/23 09:16:17 I'll rename it to rtp_transport_controller_send.h,
nisse-webrtc 2017/03/23 09:38:35 Done.
12 #define WEBRTC_CALL_RTP_TRANSPORT_CONTROLLER_H_
13
14 namespace webrtc {
15
16 class CongestionController;
17 class Module;
18 class PacketRouter;
19 class RtpPacketSender;
20 class TransportFeedbackObserver;
21 class VieRemb;
22
23 // An RtpTransportController should own everything related to the RTP
24 // transport to/from a remote endpoint. We should have separate
25 // interfaces for send and receive side, even if they are implemented
26 // by the same class. This is an ongoing refactoring project. At some
27 // point, this class should be promoted to a public api under
28 // webrtc/api/rtp/.
29 //
30 // For a start, this object is just a collection of the objects needed
31 // by the VideoSendStream constructor. The plan is to move ownership
32 // of all RTP-related objects here, and add methods to create per-ssrc
33 // objects which would then be passed to VideoSendStream. Eventually,
34 // direct accessors like remb() and packet_router() should be removed.
35 //
36 // This should also have a reference to the underlying
37 // webrtc::Transport(s). Currently, webrtc::Transport is implemented by
38 // WebRtcVideoChannel2 and WebRtcVoiceMediaChannel, and owned by
39 // WebrtcSession. Video and audio always uses different transport
40 // objects, even in the common case where they are bundled over the
41 // same underlying transport.
42 //
43 // Extracting the logic of the webrtc::Transport from BaseChannel and
44 // subclasses into a separate class seems to be a prerequesite for
45 // moving the transport here.
46 class RtpTransportControllerSendInterface {
47 public:
48 virtual ~RtpTransportControllerSendInterface() {}
49 virtual VieRemb* remb() = 0;
50 virtual PacketRouter* packet_router() = 0;
51
52 // Currently returning the same pointer, but with different types.
53 virtual CongestionController* congestion_controller() = 0;
54 virtual TransportFeedbackObserver* transport_feedback_observer() = 0;
55
56 virtual RtpPacketSender* packet_sender() = 0;
57 };
58
59 } // namespace webrtc
60
61 #endif // WEBRTC_CALL_RTP_TRANSPORT_CONTROLLER_H_
OLDNEW
« no previous file with comments | « webrtc/call/call.cc ('k') | webrtc/modules/congestion_controller/include/congestion_controller.h » ('j') | no next file with comments »

Powered by Google App Engine
This is Rietveld 408576698