Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(214)

Unified Diff: webrtc/modules/video_coding/packet.h

Issue 2614503002: Reland of Rename RTPVideoHeader.isFirstPacket to .is_first_packet_in_frame. (Closed)
Patch Set: Created 3 years, 12 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
« no previous file with comments | « webrtc/modules/video_coding/nack_module_unittest.cc ('k') | webrtc/modules/video_coding/packet.cc » ('j') | no next file with comments »
Expand Comments ('e') | Collapse Comments ('c') | Show Comments Hide Comments ('s')
Index: webrtc/modules/video_coding/packet.h
diff --git a/webrtc/modules/video_coding/packet.h b/webrtc/modules/video_coding/packet.h
index 16f568504e6f34577ae0046d4d634212883ad002..54d08c16baae876448577e43a2cc7de879c7c8c2 100644
--- a/webrtc/modules/video_coding/packet.h
+++ b/webrtc/modules/video_coding/packet.h
@@ -39,7 +39,10 @@ class VCMPacket {
FrameType frameType;
VideoCodecType codec;
- bool isFirstPacket; // Is this first packet in a frame.
+ union {
+ RTC_DEPRECATED bool isFirstPacket; // Is this first packet in a frame.
danilchap 2017/01/04 10:13:27 #include "webrtc/base/deprecation.h" to be safer
johan 2017/01/04 15:21:32 Acknowledged.
+ bool is_first_packet_in_frame;
+ };
VCMNaluCompleteness completeNALU; // Default is kNaluIncomplete.
bool insertStartCode; // True if a start code should be inserted before this
// packet.
« no previous file with comments | « webrtc/modules/video_coding/nack_module_unittest.cc ('k') | webrtc/modules/video_coding/packet.cc » ('j') | no next file with comments »

Powered by Google App Engine
This is Rietveld 408576698