Index: webrtc/modules/congestion_controller/delay_based_bwe.h |
diff --git a/webrtc/modules/congestion_controller/delay_based_bwe.h b/webrtc/modules/congestion_controller/delay_based_bwe.h |
index 0f1472e6729dbb976887caf30731d209af9a42a0..1629ac367e44d7083024224d05c699b760df3a41 100644 |
--- a/webrtc/modules/congestion_controller/delay_based_bwe.h |
+++ b/webrtc/modules/congestion_controller/delay_based_bwe.h |
@@ -20,6 +20,7 @@ |
#include "webrtc/base/rate_statistics.h" |
#include "webrtc/base/thread_checker.h" |
#include "webrtc/modules/congestion_controller/probe_bitrate_estimator.h" |
+#include "webrtc/modules/congestion_controller/theil_sen_estimator.h" |
#include "webrtc/modules/congestion_controller/trendline_estimator.h" |
#include "webrtc/modules/remote_bitrate_estimator/aimd_rate_control.h" |
#include "webrtc/modules/remote_bitrate_estimator/include/remote_bitrate_estimator.h" |
@@ -82,12 +83,15 @@ class DelayBasedBwe { |
int64_t now_ms, |
rtc::Optional<uint32_t> acked_bitrate_bps, |
uint32_t* target_bitrate_bps); |
+ const bool in_trendline_experiment_; |
brandtr
2016/11/28 16:27:19
You might want to rename this in the future, as th
terelius
2016/12/02 16:45:52
Agreed. The variable name made more sense when the
brandtr
2016/12/05 12:34:44
Acknowledged.
|
+ const bool in_theil_sen_experiment_; |
rtc::ThreadChecker network_thread_; |
Clock* const clock_; |
std::unique_ptr<InterArrival> inter_arrival_; |
std::unique_ptr<OveruseEstimator> kalman_estimator_; |
std::unique_ptr<TrendlineEstimator> trendline_estimator_; |
+ std::unique_ptr<TheilSenEstimator> theil_sen_estimator_; |
OveruseDetector detector_; |
BitrateEstimator receiver_incoming_bitrate_; |
int64_t last_update_ms_; |
@@ -98,7 +102,8 @@ class DelayBasedBwe { |
size_t trendline_window_size_; |
double trendline_smoothing_coeff_; |
double trendline_threshold_gain_; |
- const bool in_trendline_experiment_; |
+ size_t theil_sen_window_size_; |
+ double theil_sen_threshold_gain_; |
RTC_DISALLOW_IMPLICIT_CONSTRUCTORS(DelayBasedBwe); |
}; |