|
|
Created:
4 years, 1 month ago by daniela-webrtc Modified:
4 years, 1 month ago CC:
webrtc-reviews_webrtc.org, tterriberry_mozilla.com Target Ref:
refs/pending/heads/master Project:
webrtc Visibility:
Public. |
DescriptionAdd ARDSettingsModelTests to apprtcmobile_test target.
Also extract all iOS sources into a static library configuration
so it's easier to include them in the test target as well.
Also, fix a wrong test that was undiscovered because the
tests were not running
BUG=webrtc:6707
Committed: https://crrev.com/77bfd7c1b868942cdf2776283bcef26d365f97dd
Cr-Commit-Position: refs/heads/master@{#15076}
Patch Set 1 #
Total comments: 5
Patch Set 2 : Rename static library #
Messages
Total messages: 25 (12 generated)
denicija@webrtc.org changed reviewers: + kthelgason@webrtc.org, magjed@webrtc.org
https://codereview.webrtc.org/2502623002/diff/1/webrtc/examples/BUILD.gn File webrtc/examples/BUILD.gn (right): https://codereview.webrtc.org/2502623002/diff/1/webrtc/examples/BUILD.gn#newc... webrtc/examples/BUILD.gn:237: rtc_static_library("AppRTCMobile_app") { I think the names AppRTCMobile_app and AppRTCMobile should be reversed, i.e. this target should be named AppRTCMobile and the ios_app_bundle target should be named AppRTCMobile_app.
Also, you should have a newline in the CL description between the title and the actual description. Otherwise the whole CL description will be interpreted as the title and it will look weird in commit histories.
Description was changed from ========== Add ARDSettingsModelTests to apprtcmobile_test target. Also extract all iOS sources into a static library configuration so it's easier to include them in the test target as well. Also, fix a wrong test that was undiscovered because the tests were not running BUG=webrtc:6707 ========== to ========== Add ARDSettingsModelTests to apprtcmobile_test target. Also extract all iOS sources into a static library configuration so it's easier to include them in the test target as well. Also, fix a wrong test that was undiscovered because the tests were not running BUG=webrtc:6707 ==========
https://codereview.webrtc.org/2502623002/diff/1/webrtc/examples/BUILD.gn File webrtc/examples/BUILD.gn (right): https://codereview.webrtc.org/2502623002/diff/1/webrtc/examples/BUILD.gn#newc... webrtc/examples/BUILD.gn:237: rtc_static_library("AppRTCMobile_app") { On 2016/11/14 12:41:43, magjed_webrtc wrote: > I think the names AppRTCMobile_app and AppRTCMobile should be reversed, i.e. > this target should be named AppRTCMobile and the ios_app_bundle target should be > named AppRTCMobile_app. That would cause the application target name to change. Is that ok? For instance ninija -C dir/ AppRTCMobile would need to change to ninja -C dir AppRTCMobile_app I've noticed that for mac there is some key output_name. But that doesn't seem to work. Do you know of some other way to explicitly change the target name in gn?
lgtm https://codereview.webrtc.org/2502623002/diff/1/webrtc/examples/BUILD.gn File webrtc/examples/BUILD.gn (right): https://codereview.webrtc.org/2502623002/diff/1/webrtc/examples/BUILD.gn#newc... webrtc/examples/BUILD.gn:237: rtc_static_library("AppRTCMobile_app") { On 2016/11/14 12:41:43, magjed_webrtc wrote: > I think the names AppRTCMobile_app and AppRTCMobile should be reversed, i.e. > this target should be named AppRTCMobile and the ios_app_bundle target should be > named AppRTCMobile_app. For mac the static_library target is named AppRTCMobile_app later in the same file. If we change this we should rename that target as well. https://codereview.webrtc.org/2502623002/diff/1/webrtc/examples/BUILD.gn#newc... webrtc/examples/BUILD.gn:237: rtc_static_library("AppRTCMobile_app") { On 2016/11/14 13:28:00, denicija-webrtc wrote: > I've noticed that for mac there is some key output_name. But that doesn't seem > to work. Do you know of some other way to explicitly change the target name in > gn? From browsing through build/config/ios/rules.gni it looks to me like the output_name is not available for the ios_app_bundle target. It does not seem worth it to me to change this, and have the app called AppRTCMobile_app.app. I agree that the naming is confusing, perhaps we can just change this to AppRTCMobile_lib ?
https://codereview.webrtc.org/2502623002/diff/1/webrtc/examples/BUILD.gn File webrtc/examples/BUILD.gn (right): https://codereview.webrtc.org/2502623002/diff/1/webrtc/examples/BUILD.gn#newc... webrtc/examples/BUILD.gn:237: rtc_static_library("AppRTCMobile_app") { On 2016/11/14 13:40:48, kthelgason wrote: > On 2016/11/14 13:28:00, denicija-webrtc wrote: > > I've noticed that for mac there is some key output_name. But that doesn't seem > > to work. Do you know of some other way to explicitly change the target name in > > gn? > > From browsing through build/config/ios/rules.gni it looks to me like the > output_name is not available for the ios_app_bundle target. It does not seem > worth it to me to change this, and have the app called AppRTCMobile_app.app. I > agree that the naming is confusing, perhaps we can just change this to > AppRTCMobile_lib ? > I see. Let's keep the ios_app_bundle target name AppRTCMobile. But then I would like to rename this target to e.g. AppRTCMobile_lib like Kári suggests.
On 2016/11/14 13:54:43, magjed_webrtc wrote: > https://codereview.webrtc.org/2502623002/diff/1/webrtc/examples/BUILD.gn > File webrtc/examples/BUILD.gn (right): > > https://codereview.webrtc.org/2502623002/diff/1/webrtc/examples/BUILD.gn#newc... > webrtc/examples/BUILD.gn:237: rtc_static_library("AppRTCMobile_app") { > On 2016/11/14 13:40:48, kthelgason wrote: > > On 2016/11/14 13:28:00, denicija-webrtc wrote: > > > I've noticed that for mac there is some key output_name. But that doesn't > seem > > > to work. Do you know of some other way to explicitly change the target name > in > > > gn? > > > > From browsing through build/config/ios/rules.gni it looks to me like the > > output_name is not available for the ios_app_bundle target. It does not seem > > worth it to me to change this, and have the app called AppRTCMobile_app.app. I > > agree that the naming is confusing, perhaps we can just change this to > > AppRTCMobile_lib ? > > > > I see. Let's keep the ios_app_bundle target name AppRTCMobile. But then I would > like to rename this target to e.g. AppRTCMobile_lib like Kári suggests. Yes, AppRTCMobile_lib sounds like better name. I also changed the Mac naming for consistency.
lgtm
The CQ bit was checked by denicija@webrtc.org
The patchset sent to the CQ was uploaded after l-g-t-m from kthelgason@webrtc.org Link to the patchset: https://codereview.webrtc.org/2502623002/#ps20001 (title: "Rename static library")
CQ is trying da patch. Follow status at https://chromium-cq-status.appspot.com/v2/patch-status/codereview.webrtc.org/...
The CQ bit was unchecked by commit-bot@chromium.org
Try jobs failed on following builders: win_x64_clang_dbg on master.tryserver.webrtc (JOB_FAILED, http://build.chromium.org/p/tryserver.webrtc/builders/win_x64_clang_dbg/build...)
The CQ bit was checked by denicija@webrtc.org to run a CQ dry run
Dry run: CQ is trying da patch. Follow status at https://chromium-cq-status.appspot.com/v2/patch-status/codereview.webrtc.org/...
The CQ bit was unchecked by commit-bot@chromium.org
Dry run: This issue passed the CQ dry run.
The CQ bit was checked by denicija@webrtc.org
CQ is trying da patch. Follow status at https://chromium-cq-status.appspot.com/v2/patch-status/codereview.webrtc.org/...
Message was sent while issue was closed.
Description was changed from ========== Add ARDSettingsModelTests to apprtcmobile_test target. Also extract all iOS sources into a static library configuration so it's easier to include them in the test target as well. Also, fix a wrong test that was undiscovered because the tests were not running BUG=webrtc:6707 ========== to ========== Add ARDSettingsModelTests to apprtcmobile_test target. Also extract all iOS sources into a static library configuration so it's easier to include them in the test target as well. Also, fix a wrong test that was undiscovered because the tests were not running BUG=webrtc:6707 ==========
Message was sent while issue was closed.
Committed patchset #2 (id:20001)
Message was sent while issue was closed.
Description was changed from ========== Add ARDSettingsModelTests to apprtcmobile_test target. Also extract all iOS sources into a static library configuration so it's easier to include them in the test target as well. Also, fix a wrong test that was undiscovered because the tests were not running BUG=webrtc:6707 ========== to ========== Add ARDSettingsModelTests to apprtcmobile_test target. Also extract all iOS sources into a static library configuration so it's easier to include them in the test target as well. Also, fix a wrong test that was undiscovered because the tests were not running BUG=webrtc:6707 Committed: https://crrev.com/77bfd7c1b868942cdf2776283bcef26d365f97dd Cr-Commit-Position: refs/heads/master@{#15076} ==========
Message was sent while issue was closed.
Patchset 2 (id:??) landed as https://crrev.com/77bfd7c1b868942cdf2776283bcef26d365f97dd Cr-Commit-Position: refs/heads/master@{#15076} |