Index: webrtc/audio/audio_receive_stream.cc |
diff --git a/webrtc/audio/audio_receive_stream.cc b/webrtc/audio/audio_receive_stream.cc |
index 9c253894719278a48b354763b4aef0a3235d0817..2bbea863622cd7f2df6fcf9569f0441fbe64c68f 100644 |
--- a/webrtc/audio/audio_receive_stream.cc |
+++ b/webrtc/audio/audio_receive_stream.cc |
@@ -18,9 +18,9 @@ |
#include "webrtc/audio/conversion.h" |
#include "webrtc/base/checks.h" |
#include "webrtc/base/logging.h" |
+#include "webrtc/base/timeutils.h" |
#include "webrtc/modules/congestion_controller/include/congestion_controller.h" |
#include "webrtc/modules/remote_bitrate_estimator/include/remote_bitrate_estimator.h" |
-#include "webrtc/system_wrappers/include/tick_util.h" |
#include "webrtc/voice_engine/channel_proxy.h" |
#include "webrtc/voice_engine/include/voe_base.h" |
#include "webrtc/voice_engine/include/voe_codec.h" |
@@ -170,7 +170,7 @@ bool AudioReceiveStream::DeliverRtp(const uint8_t* packet, |
// video and shouldn't be mixed. |
if (remote_bitrate_estimator_ && |
header.extension.hasTransportSequenceNumber) { |
- int64_t arrival_time_ms = TickTime::MillisecondTimestamp(); |
+ int64_t arrival_time_ms = rtc::Time64(); |
stefan-webrtc
2016/04/19 09:19:12
Is there a function with a better name? I'd prefer
nisse-webrtc
2016/04/19 12:19:25
There's another pending transition, I think. There
stefan-webrtc
2016/04/19 12:40:47
I'd prefer an int64_t TimeMilliseconds() and maybe
nisse-webrtc
2016/04/19 13:48:50
I think int64_t is enough, no need for templates.
|
if (packet_time.timestamp >= 0) |
arrival_time_ms = (packet_time.timestamp + 500) / 1000; |
size_t payload_size = length - header.headerLength; |