Index: webrtc/p2p/base/stun.h |
diff --git a/webrtc/p2p/base/stun.h b/webrtc/p2p/base/stun.h |
index 9c8471304b48aeadce058f608ad34337acef57e7..a55b81c6f0c4e71e641802803afec61b3ee7acc1 100644 |
--- a/webrtc/p2p/base/stun.h |
+++ b/webrtc/p2p/base/stun.h |
@@ -606,7 +606,10 @@ enum IceAttributeType { |
STUN_ATTR_USE_CANDIDATE = 0x0025, // No content, Length = 0 |
STUN_ATTR_ICE_CONTROLLED = 0x8029, // UInt64 |
STUN_ATTR_ICE_CONTROLLING = 0x802A, // UInt64 |
- STUN_ATTR_NETWORK_COST = 0xC057 // UInt32 |
+ STUN_ATTR_NETWORK_COST = 0xC057, // UInt32. Deprecated |
+ // UInt32. The higher 16 bits are the network ID. The lower 16 bits are the |
+ // network cost. |
+ STUN_ATTR_NETWORK_INFO = 0xC058 |
pthatcher1
2016/03/21 17:49:24
I think we could just rename 0xC057 to STUN_ATTR_N
honghaiz3
2016/03/22 16:30:03
I am afraid of potential confusions between an old
|
}; |
// RFC 5245-defined errors. |
@@ -622,6 +625,7 @@ class IceMessage : public StunMessage { |
switch (type) { |
case STUN_ATTR_PRIORITY: |
case STUN_ATTR_NETWORK_COST: |
+ case STUN_ATTR_NETWORK_INFO: |
return STUN_VALUE_UINT32; |
case STUN_ATTR_USE_CANDIDATE: return STUN_VALUE_BYTE_STRING; |
case STUN_ATTR_ICE_CONTROLLED: return STUN_VALUE_UINT64; |