Index: webrtc/modules/video_processing/frame_preprocessor.h |
diff --git a/webrtc/modules/video_processing/frame_preprocessor.h b/webrtc/modules/video_processing/frame_preprocessor.h |
index c5313b406680b6768d374ce849909ed9830028df..c1cc3592ae3f7d90a1b47931fa1c7ec220c741b9 100644 |
--- a/webrtc/modules/video_processing/frame_preprocessor.h |
+++ b/webrtc/modules/video_processing/frame_preprocessor.h |
@@ -18,6 +18,7 @@ |
#include "webrtc/modules/video_processing/content_analysis.h" |
#include "webrtc/modules/video_processing/spatial_resampler.h" |
#include "webrtc/modules/video_processing/video_decimator.h" |
+#include "webrtc/modules/video_processing/video_denoiser.h" |
#include "webrtc/typedefs.h" |
namespace webrtc { |
@@ -65,11 +66,14 @@ class VPMFramePreprocessor { |
enum { kSkipFrameCA = 2 }; |
VideoContentMetrics* content_metrics_; |
+ VideoFrame denoised_frame_; |
mflodman
2015/11/25 12:15:19
Already from earlier, but we should have #include
mflodman
2015/11/25 12:15:19
And I'd prefer to call this just 'denoiser_', sinc
stefan-webrtc
2015/11/25 12:16:52
Sounds good to me.
jackychen
2015/11/25 20:29:05
Done.
jackychen
2015/11/25 20:29:05
Done.
|
VideoFrame resampled_frame_; |
VPMSpatialResampler* spatial_resampler_; |
VPMContentAnalysis* ca_; |
VPMVideoDecimator* vd_; |
+ VideoDenoiser* video_denoiser_; |
bool enable_ca_; |
+ bool enable_denoising_; |
int frame_cnt_; |
}; |