Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(824)

Unified Diff: webrtc/modules/audio_coding/main/acm2/codec_manager.h

Issue 1432553007: Rename Maybe to Optional (Closed) Base URL: https://chromium.googlesource.com/external/webrtc.git@master
Patch Set: a -> an Created 5 years, 1 month ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
Index: webrtc/modules/audio_coding/main/acm2/codec_manager.h
diff --git a/webrtc/modules/audio_coding/main/acm2/codec_manager.h b/webrtc/modules/audio_coding/main/acm2/codec_manager.h
index 26b5a2802ecbe7558bf114dd5e7091f2dcd5f48a..bd8cb7660dabc3a08c72310d7c9868123b4e50d8 100644
--- a/webrtc/modules/audio_coding/main/acm2/codec_manager.h
+++ b/webrtc/modules/audio_coding/main/acm2/codec_manager.h
@@ -12,7 +12,7 @@
#define WEBRTC_MODULES_AUDIO_CODING_MAIN_ACM2_CODEC_MANAGER_H_
#include "webrtc/base/constructormagic.h"
-#include "webrtc/base/maybe.h"
+#include "webrtc/base/optional.h"
#include "webrtc/base/scoped_ptr.h"
#include "webrtc/base/thread_checker.h"
#include "webrtc/modules/audio_coding/main/acm2/codec_owner.h"
@@ -35,7 +35,7 @@ class CodecManager final {
void RegisterEncoder(AudioEncoder* external_speech_encoder);
- rtc::Maybe<CodecInst> GetCodecInst() const;
+ rtc::Optional<CodecInst> GetCodecInst() const;
bool SetCopyRed(bool enable);

Powered by Google App Engine
This is Rietveld 408576698