Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(712)

Unified Diff: webrtc/call/congestion_controller.h

Issue 1419803002: Rename ChannelGroup to CongestionController and move to webrtc/call/. (Closed) Base URL: https://chromium.googlesource.com/external/webrtc.git@master
Patch Set: Rebase Created 5 years, 2 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
« no previous file with comments | « webrtc/call/call.cc ('k') | webrtc/call/congestion_controller.cc » ('j') | no next file with comments »
Expand Comments ('e') | Collapse Comments ('c') | Show Comments Hide Comments ('s')
Index: webrtc/call/congestion_controller.h
diff --git a/webrtc/video_engine/vie_channel_group.h b/webrtc/call/congestion_controller.h
similarity index 81%
rename from webrtc/video_engine/vie_channel_group.h
rename to webrtc/call/congestion_controller.h
index d26ee108440c63da95ca9a04fc58bc76ae0b9dd6..b4242341236d1967d7e6ad83d374a27b07ac9067 100644
--- a/webrtc/video_engine/vie_channel_group.h
+++ b/webrtc/call/congestion_controller.h
@@ -8,20 +8,16 @@
* be found in the AUTHORS file in the root of the source tree.
*/
-#ifndef WEBRTC_VIDEO_ENGINE_VIE_CHANNEL_GROUP_H_
-#define WEBRTC_VIDEO_ENGINE_VIE_CHANNEL_GROUP_H_
+#ifndef WEBRTC_CALL_CONGESTION_CONTROLLER_H_
+#define WEBRTC_CALL_CONGESTION_CONTROLLER_H_
-#include <list>
-#include <map>
-#include <set>
#include <vector>
#include "webrtc/base/criticalsection.h"
#include "webrtc/base/scoped_ptr.h"
#include "webrtc/base/socket.h"
#include "webrtc/modules/bitrate_controller/include/bitrate_controller.h"
-#include "webrtc/video_receive_stream.h"
-#include "webrtc/video_send_stream.h"
+#include "webrtc/stream.h"
namespace webrtc {
@@ -39,12 +35,10 @@ class TransportFeedbackAdapter;
class ViEEncoder;
class VieRemb;
-// Channel group contains data common for several channels. All channels in the
-// group are assumed to send/receive data to the same end-point.
-class ChannelGroup : public BitrateObserver {
+class CongestionController : public BitrateObserver {
public:
- ChannelGroup(ProcessThread* process_thread, CallStats* call_stats);
- ~ChannelGroup();
+ CongestionController(ProcessThread* process_thread, CallStats* call_stats);
+ ~CongestionController();
void AddEncoder(ViEEncoder* encoder);
void RemoveEncoder(ViEEncoder* encoder);
void SetBweBitrates(int min_bitrate_bps,
@@ -63,7 +57,6 @@ class ChannelGroup : public BitrateObserver {
BitrateAllocator* bitrate_allocator() const {
return bitrate_allocator_.get(); }
TransportFeedbackObserver* GetTransportFeedbackObserver();
- RtcpIntraFrameObserver* GetRtcpIntraFrameObserver() const;
// Implements BitrateObserver.
void OnNetworkChanged(uint32_t target_bitrate_bps,
@@ -74,6 +67,7 @@ class ChannelGroup : public BitrateObserver {
private:
rtc::scoped_ptr<VieRemb> remb_;
pbos-webrtc 2015/10/21 13:15:09 TODO to rename/move?
+ // TODO(mflodman): Move bitrate_allocator_ to Call.
rtc::scoped_ptr<BitrateAllocator> bitrate_allocator_;
rtc::scoped_ptr<PacketRouter> packet_router_;
rtc::scoped_ptr<PacedSender> pacer_;
@@ -96,4 +90,4 @@ class ChannelGroup : public BitrateObserver {
} // namespace webrtc
-#endif // WEBRTC_VIDEO_ENGINE_VIE_CHANNEL_GROUP_H_
+#endif // WEBRTC_CALL_CONGESTION_CONTROLLER_H_
« no previous file with comments | « webrtc/call/call.cc ('k') | webrtc/call/congestion_controller.cc » ('j') | no next file with comments »

Powered by Google App Engine
This is Rietveld 408576698